Render device error

  • Screenshot_10.png

    This is happening all the time since a while now. When I close it (ESC. or X) or when I click Ok the game closes. This error message appears some time before this loading screen is entered and until it's fully loaded everything's just as normal ( except the message) but then it won't continue.

    I tried restarting my Laptop and also reinstalled the whole game but nothing changes. I was able to play the game before without any problems and now I'm quite confused since I don't have a clue what the meaning of this is. I do not know much about graphic cards and drivers but I'm quite sure that mine is better than DirectX 9.0c. I have a NVIDIA GeForce 940m at the version 2.4.5.44 (don't know if this is important) and the help center tells me there are no updates.

    What can I do about this?


    Edit: What I have to add is that my graphics card seems to be vanishing when any game crashes and can't be found until I restart my laptop

  • Have you possibly double checked to see if your DirectX is above 9 or at 9?


    If not, then you can easily check by typing into the search bar on your taskbar, dxdiag and it should tell you for certain what version of DirectX you're using.

    When it also pops up with a window to see if your drivers have been digitally signed, then you'll want to click Yes. :/

  • Im having the same problem. i've already reinstalled the game. I have NVIDIA GeForce GTX 950m. Directx 12. what happens is, at first it was working fine but after i try to load a map for example navea, it crashes and after it crashes whenever i try to open the game again that window (renderer device creation failed) pops up. I already tried to full check. and yes whenever i restart my laptop it lets me play again