Compatibility Issues?

  • For some reason, I am having compatibility issues with my Windows 10 Sony Vaio. I used to be able to play on Windows 8 a long time ago, but I guess something changed and now it won't let me play again (I haven't played since Windows 8). My antivirus is Kaspersky and I have tried adding the game to the exceptions (even though it was already listed under the exceptions). I tried changing the graphics processor on the game, something which allowed me to play a different game that wasn't working at first. For some reason, Aeria ignite opens, I can click play game, but the game always crashes once it finishes loading initially. I cannot get beyond the loading screen. Can somebody please help me???

  • Aeria Games doesn't support Aeria Ignite anymore for a while now.

    I suggest you redownload the game through the new webclient or Steam to be able to play properly and (hopefully) without any issues. If youre having trouble downloading from those platforms, you can also try using the Minimal Client instead.


  • I tried downloading it from steam and I still get the same issues. What could it be? It must be from some update to my computer after Windows 10 was released. Also, I misspoke when I said Aeria Ignite. I just didn't know what else to call the client...

  • Um ok, this is not supposed to happen with Steam.

    Window 10 should be compatible with the game, if you haven't tried, maybe run it in Compatible mode of Window 7 or 8.
    If the issue persist, maybe give us some images on how it crash, any window it pop up if there is, or even better: record the whole process from opening launcher to after it crashed.

    Btw, what is your laptop specs?

    What's better than a cute loli? More cute lolis.

    Gotta love this game.

  • Btw, what is your laptop specs?

    Would like to know this too. Also update your drivers to its latest version then retry.

    You should have a file called error.log in your Aura Kingdom's root folder. If you can provide that privately to me through mail, that would be helpful too.

  • I tried running it in compatibility mode and it did not work. My specs are:

    Processor: Intel (R) Core (TM) i7-4500 CPU @ 1.800GHz 2.39

    Installed RAM: 8.00 GB (7.9 GB used)

    Device ID: [Censored by GS]

    Product ID: [Censored by GS]

    System Type: 64-bit operating system, x64-based processor

    (I typed this exactly how it appears on my laptop)

    Also, there are no error windows that pop up. The game tries to load, it finishes loading, music plays for 1~2 seconds, and then the game just shuts down...